01-复杂度2 Maximum Subsequence Sum (25分)

01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1 , N2​​ , …, NK }. A continuous subsequence is defined to be { N​i, N​i+1​​ , …, N​j } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:
10 1 4

#include <stdio.h>
#include <stdlib.h>

int main() {
	int n;//输入要输入的个数
	scanf("%d", &n);
	int *a = (int *)calloc(n, sizeof(int));//为数组分配空间
	for (int i = 0; i < n; ++i) {
		scanf("%d", a + i);
	}//输入数组的各个数
	int thissum = 0;//thissum表示遍历的时候到当前数组位置的和
	int maxsum = -1;/*maxsum表示当前为止最大子列和,设为-1是因为需要处理一堆
	负数中有0的情况,用于区分全负数跟一堆负数中有0的情况,也就是maxsum需要
	跟thissum进行比较,thissum如果小于0的时候需要赋值为0,就搞不清楚是最大
	值是真正的0还是假的0*/
	int old_front = 0, old_rear = 0;/*old_front表示记录的最大值maxsum的第一
	个数的位置,old_rear表示记录的最大值maxsum的最后一个位置*/
	int new_front=0, new_rear;/*new_front表示最新的thissum的第一个数的位置,
	new_rear表示thissum的最后一个位置*/
	for (int i = 0; i < n; ++i) {//对数组a进行遍历
		thissum += a[i];
		if (maxsum < thissum) /*当maxsum小于thissum时,表明出现了新的最大值,
		所以只有这个时候才需要把最大子列和的第一个数跟最后一个数重新赋值*/
			old_front = new_front;
			new_rear = i;
			old_rear = new_rear;
			maxsum = thissum;
		}
		else if (thissum < 0) {/*当thissum小于0的时候表示当前的thissum不能
		使后边的子列的和变大,所以需要赋值为0重新计算,并且thissum的第一个
		数的位置也要改变*/
			new_front = i+1;
			thissum = 0;
		}
	}
	if (maxsum == -1)//当maxsum=-1的时候表明,数组中全是负数
		printf("0 %d %d", a[0],a[n-1]);
	else
		printf("%d %d %d", maxsum,a[old_front],a[old_rear]);
	system("pause");
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值