ZOJ 3714 水题,遍历一遍

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?
Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M ≤ N). Here N and M are defined in above description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.
Output

For each test case, output the corresponding maximum java beans the teacher can collect.
Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75

Sample Output

16
158

思路:
遍历一圈即可,少的链接前面的,像循环链表一样

#include<bits/stdc++.h>
const double PI=acos(-1.0);
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&-x
#define inf 0x3f3f3f3f
#define pr pair<int,int>
typedef pair<char,int> PAIR;
struct CmpByValue
{
    bool operator()(const PAIR& lhs, const PAIR& rhs)
    {
        return lhs.second > rhs.second;
    }
};
//priority_qe<int,vector<int>,greater<int>> pp;
const int mod = 123456789 ;
const int M = 15000 +10 ;
const int limt = 1<<20;
const int INF = 1e9;
typedef long long ll;
/*
    遍历一圈即可,少的链接前面的,像循环链表一样
*/
int mp[M];
int main()
{
    ios::sync_with_stdio(0);//加速
    int t,n,m;
    cin>>t;
    while(t--)
    {
        memset(mp,0,sizeof(0));
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        {
            cin>>mp[i];
        }

        for(int i=n+1,j=1;j<m;i++,j++)//将前m-1个元素放到最后一个元素的后面
        {
            mp[i]=mp[j];
        }

        ll sum=0,manx=0;
        for(int i=1;i<=n;i++)
        {
            sum=0;

            for(int j=i;j<i+m;j++)
            {
                sum+=mp[j];
            }

            if(sum>manx)
                manx=sum;
        }

        cout<<manx<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值