Collecting Bugs(期望dp)

Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 11729 Accepted: 5307
Case Time Limit: 2000MS Special Judge
Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria — Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It’s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan’s opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan’s work) required to name the program disgusting.
Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Output

Output the expectation of the Ivan’s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Input

1 2
Sample Output

3.0000
题目大意:一个软件有 s 个子系统,会产生 n 种 bug。某人一天发现一个 bug,这个 bug 属于某种 bug 分类,也属于某个子系统。每个 bug 属于某个子系统的概率是 ,属于某种 bug 分类的概率是 。求发现 n 种 bug,且 s 个子系统都找到 bug 的期望天数。
令dp[i][j]表示已经找到了i种bug,属于j种子系统,达到n种bug和s种子系统还需要的期望天数。那么dp[n][s]表示已经达到目标了,所以dp[n][s]=0。所以从dp[n][s]开始逆推。
对dp[i][j]的状态转移,(花费一天所找到的bug)
1.找到的bug属于已经找到i种bug和j种子系统中,概率是p1=i * j/(n * s)
2.找到的bug不属于已经找到i种bug但属于已经找到的j种子系统中,概率是 p2=(n-i)* j/(n * s)
3.找到的bug属于已经找到i种bug但不属于已经找到的j种子系统中,概率是p3= i* (s-j)/(n * s)
4.找到的bug既不属于已经找到i种bug也不属于已经找到的j种子系统中,概率是 p4=(n-i)* (s-j)/(n * s)
所以状态转移方程:
dp[i][j]=p1dp[i][j]+p2dp[i+1][j]+p3dp[i][j+1]+p4dp[i+1][j+1]+1
加的1是花费一天
因为刚开始dp[i][j]是0,所以希望等式右边没有dp[i][j],所以通过移项得:
dp[i][j]=(p2dp[i+1][j]+p3dp[i][j+1]+p4*dp[i+1][j+1]+1)/(1-p1)

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#include<string.h> 
#include<sstream>
#define ll long long
using namespace std;
const int N = 1e3+10;
const double INF = 0x3f3f3f3f;
double dp[N][N];
int main()
{
	int n,s;
	scanf("%d %d",&n,&s);
	dp[n][s]=0;
	for(int i=n;i>=0;i--)
	{
		for(int j=s;j>=0;j--)
		{
			double x=i*1.0/(n*1.0),y=j*1.0/(s*1.0);
			if(i==n&&j==s) continue;
			dp[i][j]=(dp[i+1][j]*(1.0-x)*y+dp[i][j+1]*x*(1.0-y)+dp[i+1][j+1]*(1.0-x)*(1.0-y)+1)/(1-x*y);
		}
	}
	printf("%.4f",dp[0][0]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值