poj 1160 Post Office(动态规划)

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.
Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.
Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.
Sample Input

10 5
1 2 3 6 7 9 11 22 44 50
Sample Output

9

分析:

有n个村庄,这些村庄都在一条横轴上,每个村庄都有一个在横轴上的位置xi,现在要建造m个邮局在m个村庄,问所有村庄到最近的邮局的距离之和的最小值。
dis[i][j]表示i村庄到j村庄建造一个邮局时的最小距离之和 。此时邮局建造在中间的村庄时距离之和最小 ,dis[i][j]=dis[i][j-1]+x[j]-x[(i+j)/2]
令dp[i][j]表示前i个村庄建造j个邮局,则枚举最后第二个邮局所服务的村庄k,则dp[i][j]=min(dp[i][j],dp[k][j-1]+dp[k+1][i])

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
#define ll long long
#define eps 1e-8
#define pi acos(-1)
const int N = 310;
ll a[N],dis[N][N],dp[N][N];
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=i+1;j<=n;j++)
		{
			dis[i][j]=dis[i][j-1]+a[j]-a[(i+j)/2];
		}
	}
	memset(dp,0x3f,sizeof(dp));
	for(int i=1;i<=n;i++) dp[i][1]=dis[1][i];//当前 i座村庄建造一个邮局 的最小距离 
	for(int i=2;i<=m;i++)//枚举邮局 
	{
		for(int j=i;j<=n;j++)//枚举前i座村庄 
		{
			for(int k=i-1;k<j;k++)//枚举最后第二个村庄 
			{
				dp[j][i]=min(dp[j][i],dp[k][i-1]+dis[k+1][j]);
			}
		}
	}
	printf("%lld",dp[n][m]);
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值