poj 1160 Post Office

Post Office
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13983 Accepted: 7540

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source

考的是基础数学知识呀。
可惜基础没学好搞了半天。大哭
dp[i][j]=min(dp[i][j],dp[k][j-1]+dis[k+1][i]);
k为1到i-1中的数。看方程应该可以看懂吧。
dis[i][j]=dis[i][j-1]+pos[j]-pos[(i+j)/2];

#include <iostream>
#include<string.h>
#include<stdio.h>
#define MIN(a,b) ((a)<(b)?(a):(b))
using namespace std;

int dis[310][310];//dis[i][j]记录在i和j之间建一个邮局的最小花费
int dp[310][310];//dp[i][j]记录在前i个村子建j个邮局且i村庄由前面的邮局管辖的最小花费
int pos[310];//记录村子下标
int main()
{
    int i,j,k,v,p;

    while(~scanf("%d%d",&v,&p))
    {
        for(i=1; i<=v; i++)
            scanf("%d",&pos[i]);
        memset(dp,0x3f,sizeof dp);
        memset(dis,0,sizeof dis);
        for(i=1; i<=v; i++)
        {
            for(j=i+1; j<=v; j++)
                dis[i][j]=dis[i][j-1]+pos[j]-pos[(i+j)/2];
            dp[i][1]=dis[1][i];
            dp[i][i]=0;
            //printf("dp[%d][1] %d\n",i,dp[i][1]);
            //getchar();
        }
        for(j=2; j<=p; j++)//循环必须这么写。这样才能保证要利用的前面的结果已算出
            for(i=j+1; i<=v; i++)
                for(k=1; k<i; k++)
                    dp[i][j]=MIN(dp[i][j],dp[k][j-1]+dis[k+1][i]);
        printf("%d\n",dp[v][p]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值