PTA1005

PTA1005 Spell It Right

问题描述:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10^100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

题目分析:

将字符串相加的结果用英文表达出来。
用tot表示当前sum的最高位数字,step统计位数+最后输出空格。
代码如下:

#include<iostream>
#include<cmath>
#include<string>
using namespace std;
int main()
{
	string s[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	string str;
	cin>>str;
	long long int sum=0;
	for (int i = 0; i < str.length(); i++)
	{
		sum+=str[i]-48;
	}
	long long int tot=sum;
	int step=1;
	while (tot>9)
	{
		tot/=10;
		step++;
	}
	//cout<<sum<<' '<<step<<endl;
	while (sum>=0)
	{
		tot=sum;
		while (tot>9)
		{
			tot/=10;
			//cout<<tot<<endl;
		}
		switch (tot)
		{
		case 1:cout<<s[1];break;
		case 2:cout<<s[2];break;
		case 3:cout<<s[3];break;
		case 4:cout<<s[4];break;
		case 5:cout<<s[5];break;
		case 6:cout<<s[6];break;
		case 7:cout<<s[7];break;
		case 8:cout<<s[8];break;
		case 9:cout<<s[9];break;
		case 0:cout<<s[0];break;
		default:
			break;
		}
		sum-=tot*pow(10,--step);
		if(step>0) cout<<' ';
		else break;
	}
	return 0;
}


总结

两个字符串利用string类非常方便,利用位数输出空格,一次通过。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值