短学期实践计划//杭电OJ(1085)

**Holding Bin-Laden Captive!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29847 Accepted Submission(s): 13001
Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”
Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input
1 1 3
0 0 0

Sample Output
4**

思路:该题主要分为两种思路,第一种是相对简单的方法,但不够通用;第二种是通用的母函数的思路.
第一种主要思想是观察1元和2元的硬币是否能构成4元。若能够构成4元,即为可以构成1-4元内的所有金额,加上不同数量的5之后就可以变为所有金额。此时即需输出n1+2n2+5n5+1.
第二种母函数思想,在找出所有情况之后遍历最小的不存在情况即可。
第一种代码:

#include <iostream>
using namespace std;
int main(){
    int n1,n2,n5;
    while(cin>>n1>>n2>>n5&&(n1||n2||n5)){
        if(n1==0) cout<<"1"<<endl;
        else if(n1+2*n2<4) cout<<n1+2*n2+1<<endl;
        else cout<<n1+2*n2+5*n5+1<<endl;
    }
    return 0;
}

第二种代码:

#include <iostream>
using namespace std;
#define MAX 8005
int sup[MAX],temp[MAX];
int main(){
    int n1,n2,n5;
    while(cin>>n1>>n2>>n5&&(n1||n2||n5)){
        int sum = n1+2*n2+5*n5;
        for(int i=0;i<=sum+1;i++)
            sup[i] = temp[i] = 0;
        for(int i=0;i<=n1;i++)
            sup[i] = 1;
        for(int i=0;i<=sum;i++){
            for(int j=0;j<=n2*2&&i+j<=sum;j+=2){
                temp[i+j] += sup[i];
            }
        }
        for(int j=0;j<=sum;j++){
            sup[j] = temp[j];
            temp[j] = 0;
        }
        for(int i=0;i<=sum;i++){
            for(int j=0;j<=n5*5&&i+j<=sum;j+=5){
                temp[i+j] += sup[i];
            }
        }
        for(int j=0;j<=sum;j++){
            sup[j] = temp[j];
            temp[j] = 0;
        }
        for(int i=0;i<=sum+1;i++){
            if(sup[i]==0){
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值