链表(顺序建表)//顺序逆序不同点在于,插入新结点每次是在头结点之后(逆序)还是最后一个结点之后(顺序),:特点:无论哪种建表方式,尾结点指针域都是NULL

Logout
数据结构实验之链表一:顺序建立链表
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。
Input
第一行输入整数的个数N;
第二行依次输入每个整数。
Output
输出这组整数。
Sample Input
8
12 56 4 6 55 15 33 62
Sample Output
12 56 4 6 55 15 33 62
Hint
不得使用数组!
Source
#include <stdio.h>
#include <stdlib.h>
struct st {int data;struct st *next;};
int main()
{
int n,i;
struct st *head,p,tail;
head=(struct st
)malloc(sizeof(struct st));//头结点的空间申请
head->next=NULL;//定义头结点后为空结点
tail=head;//设置尾指针,一直保存最后一个结点,当链表顺序插入结点后尾指针的值要随之修改,以指向新结点。
scanf("%d",&n);
for(i=0;i<n;i++)
{
p=(struct st
)malloc(sizeof(struct st));//申请工作结点空间
scanf("%d",&p->data);
p->next=NULL;//在逆序建表中这里指向head->next;这里是让p后面尾结点为空
tail->next=p;//将p插入tail后面
tail=p;//将尾结点放在最后,以便下一次使用。
}
p=head;
while(p->next!=NULL)
{
printf("%d ",p->next->data);
p=p->next;
}
return 0;
}

/***************************************************
两种方式(第二种利用的是函数)
****************************************************/
Source
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int data;
struct node *next;
};
struct node *creatseq(int n);
void display(struct node *head);

int main()
{
struct node *head;
int n;

scanf("%d", &n);
head = creatseq(n);
display(head);

return 0;

}
struct node *creatseq(int n)
{
struct node *head, *tail, *p;
int i;
head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
tail = head;
for(i = 0; i < n; i++)
{
p = (struct node *)malloc(sizeof(struct node));
scanf("%d", &p->data);
p->next = NULL;
tail->next = p;
tail = p;
}
return head;
}
void display(struct node *head)
{
struct node *p;
p = head->next;
while§
{
printf("%d%c", p->data, p->next == NULL ? ‘\n’ : ’ ');
p = p->next;
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值