贪心 HDU2069 Coin Change

 Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score. 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

解题报告:这道题看了很久没多大思路,看了网上的题解,不过贪心的题目是真的一点没思路啊。。这题的贪心策略的是按照分数大小先排序,先把分数大的安排的尽量靠后并且在它的deadline前面,如果前面都被安排完了就必须罚分了。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<set>
#define IL inline
#define x first
#define y second
typedef long long ll;
using namespace std;
typedef pair<int,int>	PII;
const	int N=1010;
bool vis[N];
PII q[N];
bool cmp(PII a,PII b)
{
	if(a.y!=b.y)
	return a.y>b.y;
	return a.x<b.x;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(vis,0,sizeof vis);
		int n;
		cin>>n;
		for(int i=0;i<n;i++)
		cin>>q[i].x;
		for(int i=0;i<n;i++)
		cin>>q[i].y;
		sort(q,q+n,cmp);		
		ll res=0;
		for(int i=0;i<n;i++)
		{
			int j=q[i].x;
			for(;j>=1;j--)
			{
				if(!vis[j])
				{
					vis[j]=1;
					break;
				}
			}
			if(j==0)	res+=q[i].y;
		}
		cout<<res<<endl;
	}
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值