Throwing cards away I UVA - 10935

  Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:

  Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck.

  Your task is to find the sequence of discarded cards and the last, remaining card.

在这里插入图片描述

Input

  Each line of input (except the last) contains a number n≤ 50. The last line contains ‘0’ and this line should not be processed.

Output

  For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input

7
19
10
6
1
0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4
Discarded cards:
Remaining card: 1

HINT

  简单的队列操作,需要注意的是当n=1时应该如何输出,第一行后面无空格,具体键上面样例输入。

Accepted

#include<iostream>
#include<queue>
using namespace std;
int main()
{
	int n,t;
	while (cin>>n&&n)
	{
		queue<int>game;
		for (int i = 1;i <= n;i++)game.push(i);
		cout << "Discarded cards:";
		for (int i = 1;game.size() > 1;i++)
		{
			cout << " " << game.front();
			game.pop();
			game.push(game.front());
			game.pop();
			if (game.size() > 1)cout << ",";
		}
		cout << endl << "Remaining card: " << game.front() << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值