Prime Ring Problem UVA - 524

A ring is composed of n (even number) circles as shown in diagram. Put natural numbers 1*,2,…,n* into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
在这里插入图片描述

Note: the number of first circle should always be 1.

Input

n (0 < n ≤16)

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.

You are to write a program that completes above process.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

HINT

回溯法解决,直接无脑暴力破解工作量巨大。结合使用深度优先遍历递归,每次递归完成之后将其恢复原状,大大节省时间。另外,由于n<=16,最大的和素数为31,直接枚举出来即可。

Accepted

#include<iostream>
#include<algorithm>
#include<cstring>
#include<set>
#include<vector>
using namespace std;
int n, Case = 0;
vector<int>list; int vis[17] = { 0 };
set<int>prime_number = { 2,3,5,7,11,13,17,19,23,29,31 };
void dfs(int num) {
	if (num == n && prime_number.count(list.front() + list.back()))
		for (int i = 0; i < n; i++)cout << list[i] << (i == n - 1 ? '\n' : ' ');
	else for(int i=2;i<=n;i++)
		if (!vis[i] && prime_number.count(i + list.back())) {
			list.push_back(i); vis[i] = 1;
			dfs(num + 1);
			list.pop_back(); vis[i] = 0;
		}
}
int main() {
	while (cin >> n) {
		cout << (Case == 0 ? "" : "\n");
		memset(vis, 0, sizeof(vis));
		list.clear();
		cout <<"Case " << ++Case <<':'<< endl;
		list.push_back(1); vis[1] = 1;
		dfs(1);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值