Quadtrees UVA - 297

  A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

  Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.

  A modern computer artist works with black-and-white images of 32×32 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

  This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.

  In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

Input

  The first line of input specifies the number of test cases (N) your program has to process.

  The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter ‘p’ indicates a parent node, the letter ‘f’ (full) a black quadrant and the letter ‘e’ (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

Output

  For each test case, print on one line the text ‘There are X black pixels.’, where X is the number of black pixels in the resulting image.

Sample Input

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

Sample Output

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.

HINT

显式建树操作,类似于建立二叉树。建树过程使用递归操作,一共建立两颗树,对比解决,并最终输出结果。

Accepted

#include<bits/stdc++.h>
using namespace std;

struct tree {
	int flag;
	tree* p1 = NULL, * p2 = NULL, * p3 = NULL, * p4 = NULL;
};

tree* build(string s, int &i) {				//建树
	tree* head = new tree;
	head->flag = s[i] == 'f' ? 1 : 0;
	if (s[i++] == 'p') {
		head->p1 = build(s, i);
		head->p2 = build(s, i);
		head->p3 = build(s, i);
		head->p4 = build(s, i);
	}
	return head;
}
int solve(tree* head1, tree* head2, int i) {//计算
	int sum = 0;
	if (head1 && head1->flag || head2 && head2->flag)sum = i * i;	//不为空并且数据域为1;
	else if(head1&&head2){
		sum += solve(head1->p1, head2->p1, i / 2);
		sum += solve(head1->p2, head2->p2, i / 2);
		sum += solve(head1->p3, head2->p3, i / 2);
		sum += solve(head1->p4, head2->p4, i / 2);
	}
	return sum;
}
void remove(tree* head) {		//删除
	if (head) {
		remove(head->p1);
		remove(head->p2);
		remove(head->p3);
		remove(head->p4);
	}
	delete head;
	return;
}

int main(){
	int sum,ans=0;
	string s1,s2;
	cin >> sum;getchar();
	while (sum--) {
		getline(cin, s1);
		getline(cin, s2);
		tree* head1 = build(s1, ans=0);
		tree* head2 = build(s2, ans=0);
		cout << "There are " << solve(head1, head2, 32) << " black pixels." << endl;
		remove(head1);
		remove(head2);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值