pat刷题(甲级1002)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

<span style="color:#212529"><span style="background-color:#ffffff"><span style="color:#212529"><code class="language-in">2 1 2.4 0 3.2
2 2 1.5 1 0.5</code></span></span></span>
结尾无空行

Sample Output:

<span style="color:#212529"><span style="background-color:#ffffff"><span style="color:#212529"><span style="background-color:var(--bg-base)"><code class="language-out">3 2 1.5 1 2.9 0 3.2</code></span></span></span></span>
结尾无空行
/*
	1.系数为0则不输出
	2.保留一位小数
	3.结尾无空格 
*/
#include<bits/stdc++.h>
using namespace std;
int main() {
	int n1,n2;
	double a[1001]={0};
	cin>>n1;
	while(n1--){
		int i;
		double j;
		cin>>i>>j;
		a[i]+=j;
	}
	cin>>n2;
	while(n2--){
		int i;
		double j;
		cin>>i>>j;
		a[i]+=j;
	}
	
	int sum=0;
	for(int k=0;k<1001;k++){
		if(a[k]!=0) sum++;
	}
	cout<<sum;
	for(int k=1000;k>=0;k--){
		if(a[k]!=0) cout<<" "<<k<<" "<<fixed<<setprecision(1)<<a[k];
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值