This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
#include <stdio.h>
const int maxn = 1111;
int main(void)
{
int count = 0;
int n;
int c;
double x;
double arr[maxn] = {0};
for(int i = 0; i < 2; i++)
{
scanf("%d", &n);
for(int j = 0; j < n; j++)
{
scanf("%d%lf", &c, &x);
arr[c] += x;
}
}
for(int i = 0; i < maxn; i++)
{
if(arr[i] != 0)
{
count++;
}
}
printf("%d", count);
for(int i = maxn - 1; i >= 0; i--)
{
if(arr[i] != 0)
{
printf(" %d %.1f", i, arr[i]);
}
}
return 0;
}