Strange function(三分查找实例)

Strange function

题目描述

Now, here is a function:
F(x)=6x7+8x6+7x3+5x2-y*x(0<=x<=100)
Can you find the minimum value when x is between 0 and 100.

翻译:

现在,这里有一个函数:
F(x)=6x7+8x6+7x3+5x2-y*x(0<=x<=100)
当x在0到100之间时,你能找到最小值吗。

输入

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

翻译:

输入的第一行包含一个整数T(1<=T<=100),表示测试用例的数量。然后T行跟随,每行只有一个实数Y。(0<Y<1e10)

输出

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

翻译:

当x在0到100之间时的最小值(精确到4位小数)。

样例输入

2
100
200

样例输出

-74.4291
-178.8534

提示

凸函数和凹函数求极值可以用三分查找来实现。

代码

#include<bits/stdc++.h>
#define ll long long
using namespace std;

double f(double x,double y){
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}

int main(){
    int n;
    scanf("%d",&n);
    double x,y;
    while(n--){
        scanf("%lf",&y);
        double l=0,r=100;
        double mid,mm;
        while(r-l>1e-4){//精确到小数点后四位
            mid=(l+r)/2;
            mm=(mid+r)/2;
            if(f(mid,y)<f(mm,y)) r=mm;
            else l=mid;
        }
        x=f(l,y);
        printf("%.4lf\n",x);
    }
    return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值