Hdu1548-A strange lift

题目链接:
传送门

Problem Description:
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?

Input:
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,…kn.
A single 0 indicate the end of the input.

Output:
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.

Sample Input:
5 1 5
3 3 1 2 5
0

Sample Output:
3

Dijkstra算法求解参考代码:

#include <stdio.h>
#include <string.h>

#define INF 0x3f3f3f3f

int n,a,b;
int map[201][201];
int dist[201];
int visited[201];

void dijkstra()
{
	memset(visited,0,sizeof(visited));
	int i,j;
	for(i=1;i<=n;i++)
	 dist[i]=map[a][i];
	 
	 visited[a]=1;
	 
	 for(i=1;i<n;i++)
	 {
	 	int min=INF,pos=-1;
	 	for(j=1;j<=n;j++)
	 	{
	 		if(visited[j]==0&&dist[j]<min)
	 		{
	 			min=dist[j];
	 			pos=j;
			 }
		 }
		 
		 if(pos==-1)
		  break;
		 else
		 visited[pos]=1;
		 
		 for(j=1;j<=n;j++)
		 {
		 	if(visited[j]==0&&dist[j]>dist[pos]+map[pos][j])
		 	 dist[j]=dist[pos]+map[pos][j];
		 } 
	 }
}

int main()
{
	int i,t;
	
	while(scanf("%d",&n)!=EOF&&n!=0)
   {
	scanf("%d%d",&a,&b);
	
	memset(map,INF,sizeof(map));
	for(i=1;i<=n;i++)
	 map[i][i]=0;
    
	for(i=1;i<=n;i++)
	{
		scanf("%d",&t);
		if(i-t>=1)
		 map[i][i-t]=1;
		if(i+t<=n)
		 map[i][i+t]=1;
	}
	
	dijkstra();
	
	if(dist[b]!=INF)
	 printf("%d\n",dist[b]);
	else
	 printf("-1\n");
	}	
	return 0;
}

BFS解法:

#include <iostream>
#include <queue>
#include <cstring>
#include <string>

using namespace std;

struct node{
	int x;//当前所在的楼梯层。 
	int num;//次数。 
};

int n,a,b;
int visited[201];
int data[201];

int bfs()
{
    memset(visited,0,sizeof(visited));
	node t,temp;
	t.x=a;
	t.num=0;
	
	queue<node>Q;
	Q.push(t);
	visited[a]=1;
	
	int up,down;
	while(Q.empty()==0)
	{
		temp=Q.front();
		Q.pop();
		if(temp.x==b)
		 return temp.num;
		
		up=temp.x+data[temp.x];
		if(visited[up]==0&&up<=n)
		{
			visited[up]=1;
			t.x=up;
			t.num=temp.num+1;
			Q.push(t);
		 }
		 
		 down=temp.x-data[temp.x];
		 if(visited[down]==0&&down>0)
		 {
		 	visited[down]=1;
		 	t.x=down;
		 	t.num=temp.num+1;
		 	Q.push(t);
		 }
	}
	
	return -1;
}

int main()
{
	int i;
	while(scanf("%d",&n)!=EOF&&n!=0)
	{
      scanf("%d%d",&a,&b);
      for(i=1;i<=n;i++)
       scanf("%d",&data[i]);
      
      printf("%d\n",bfs());
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值