1006 Sign In and Sign Out(模拟,排序)

1006 Sign In and Sign Out

0、题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

1、大致题意

输入每个人的名字和进门、出门的时间,要求找到开门(最先进门)和锁门(最后出门)的人。

2、基本思路

实现一个 employee的结构体,里面用 string存储 ID numbers,用 int存储 HH:MM:SS,然后用 sort大法

3、 解题过程

3.1 使用 scanf读入 string

c语言中没有 string类型,直接用 scanf读入 string类型是不正确的。那么如何 使用 scanf读入 string

scanf是标准输入流,没有缓存区,需要预先分配空间,而 cin是输入流,它使用了缓冲区。如果要使用 scanf读入字符串,那就一定要事先为它申请足够的内存空间。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
	string a,b;
	a.resize(8) ;
	b.resize(8) ;
	scanf("%s%s",&a[0],&b[0]) ;
	printf("%s=%s\n",a.c_str(),b.c_str()) ;
	return 0;
}
输入:fgdsfsa 234sfa
输出:fgdsfsa=234sfa

如果要对结构体的 stringscanf的话,在结构体中需要初始化申请内存空间

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct id {
	string name ;
	id() {
		name .resize (8) ;
	}
} v[2];

int main() {
	scanf("%s%s",&v[0].name[0],&v[1].name[0]);
	printf("%s=%s\n",v[0].name.c_str(),v[1].name.c_str()) ;
	return 0;
}

3.2 AC代码

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct employee {
	string ID_number;
	int HH,MM,SS; //Sign_in_time
	int hh,mm,ss; //Sign_out_time
} ;
int n;
vector<employee> emp;
employee temp;

int cmp1(employee a,employee b) {
	if(a.HH!=b.HH) return a.HH<b.HH;
	else if(a.MM!=b.MM) return a.MM<b.MM;
	else if(a.SS!=b.SS) return a.SS<=b.SS;
}

int cmp2(employee a,employee b) {
	if(a.hh!=b.hh) return a.hh>b.hh;
	else if(a.mm!=b.mm) return a.mm>b.mm;
	else if(a.ss!=b.ss) return a.ss>=b.ss;
}

int main() {
	cin>>n;
	for(int i=0; i<n; i++) {
		cin>>temp.ID_number;
		scanf("%d:%d:%d%d:%d:%d",&temp.HH,&temp.MM,&temp.SS,&temp.hh,&temp.mm,&temp.ss);
		emp.push_back(temp);
	}
	sort(emp.begin(),emp.end(),cmp1);
	cout<<emp[0].ID_number;
	sort(emp.begin(),emp.end(),cmp2);
	cout<<" "<<emp[0].ID_number;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值