【PAT(甲级)】1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

解题思路:

很简单的一道水题,题目大意是最早进机房的人开门,最后一个走的人关门(我一开始还想叉了,以为是不交叉的时间内一个人进出的话要自己开门关门),题目实际上就是给出M个人的进入和离开机房的时间,让你找出最早进入机房的人,和最晚离开机房的人。

所以显而易见的只要把数据读入一个结构里,然后比较时间的先后,再把相应的ID输出就可以得到满分啦。时间的存储类型的话,c++自带的tm类可以定义。

易错点:

读取时间的时候,要么用string类型直接读取,然后自己处理数据。如果用int类型的读取的话记得把数字之间的“:”处理一下,不然读取时会产生错误。

代码:

#include<bits/stdc++.h>
#include<stdio.h>
using namespace std;

typedef struct person{//一个结构用来存储人的ID,以及进入和离开机房的时间 
	string ID_number;
	tm Sign_in_time;
	tm Sign_out_time;
};

int t_min(person a){//计算最早进入机房的时间 
	return 	a.Sign_in_time.tm_hour*3600+a.Sign_in_time.tm_min*60+a.Sign_in_time.tm_sec;
}

int t_max(person a){//计算最晚离开机房的时间 
	return 	a.Sign_out_time.tm_hour*3600+a.Sign_out_time.tm_min*60+a.Sign_out_time.tm_sec;
}

string R_min(person a[],int b){//返回最早进入机房的人的ID 
	string r;
	int min = t_min(a[0]);
	for(int i=0;i<b;i++){
		if(min>=t_min(a[i])){
			min=t_min(a[i]);
			r=a[i].ID_number;
		}	
	}
	return r;
}

string R_max(person a[],int b){//返回最晚离开机房人的ID 
	string r;
	int max = t_max(a[0]);
	for(int i=0;i<b;i++){
		if(max<=t_max(a[i])){
			max=t_max(a[i]);
			r=a[i].ID_number;
		}	
	}
	return r;
}

int main(){
	int M;
	string b;
	cin>>M;
	person P[M];
	
	for(int i=0;i<M;i++){//按要求读入人员信息 
		cin>>P[i].ID_number;
		scanf("%d:%d:%d",&P[i].Sign_in_time.tm_hour,&P[i].Sign_in_time.tm_min,&P[i].Sign_in_time.tm_sec);
		scanf("%d:%d:%d",&P[i].Sign_out_time.tm_hour,&P[i].Sign_out_time.tm_min,&P[i].Sign_out_time.tm_sec);
	}
	
	cout<<R_min(P,M)<<" "<<R_max(P,M);
	
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值