1023 Have Fun with Numbers

1023 Have Fun with Numbers

0、题目

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

1、大致题意

给出一个长度不超过20的整数,问这个整数两倍后的数位是否为原数位的一个排列。不管是yes还是no最后都要输出整数乘以2的结果

2、基本思路

简单题

3、AC代码

#include <cstdio>
#include <string.h>
using namespace std;
int book[10];
int main() {
	char num[22];
	scanf("%s", num);
	int flag = 0, len = strlen(num);
	for(int i = len - 1; i >= 0; i--) {
		int temp = num[i] - '0';
		book[temp]++;
		temp = temp * 2 + flag;
		flag = 0;
		if(temp >= 10) {
			temp = temp - 10;
			flag = 1;
		}
		num[i] = (temp + '0');
		book[temp]--;
	}
	int flag1 = 0;
	for(int i = 0; i < 10; i++) {
		if(book[i] != 0)
			flag1 = 1;
	}
	printf("%s", (flag == 1 || flag1 == 1) ? "No\n" : "Yes\n");
	if(flag == 1) printf("1");
	printf("%s", num);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值