A1125 Chain the Ropes(25分)PAT 甲级(Advanced Level) Practice(C++)满分题解【排序】

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题意分析:

题目要求是要求所有绳索连接起来的最大长度,注意每次进行两个绳索连接操作的话,该两条绳索的长度之和就要除以2,并舍去小数,所以如果要使最后的和最大,那么就要让最长的绳索做的折半次数最少,故在获取所有绳索后先做一个从小到大的排序处理,从小到大依次折半,越小的折半后损失的长度最小。

代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n;
	cin >> n;
	vector<int> vec(n);
	for (int i = 0; i < n; i++) {
		cin >> vec[i];
	}
	sort(vec.begin(), vec.end());
	int index = 0;
	while (index!=n-1) {
		int temp = (vec[index] + vec[index + 1]) / 2;
		index++;
		vec[index] = temp;
	}
	cout << vec[index] << endl;
	return 0;
}

运行结果如下: 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值