After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:
ID Score School
where ID
is a string of 6 characters with the first one representing the test level: B
stands for the basic level, A
the advanced level and T
the top level; Score
is an integer in [0, 100]; and School
is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID
is unique for each testee.
Output Specification:
For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:
Rank School TWS Ns
where Rank
is the rank (start from 1) of the institution; School
is the institution code (all in lower case); ; TWS
is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5
, where ScoreX
is the total score of the testees belong to this institution on level X
; and Ns
is the total number of testees who belong to this institution.
The institutions are ranked according to their TWS
. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns
. If there is still a tie, they shall be printed in alphabetical order of their codes.
Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2
题意分析:
首先定义结构体,这里主要是注意map是自动按key值进行排序,所以不能直接定义cmp排序条件,所以需要先转化为vector再使用sort
vector<pair<string, institution>> vec(inslist.begin(), inslist.end());
在输出排名的时候,加入一个tmp变量来记录当前的正常序号,当发现与前一个机构的分数不一样的时候就用tmp来更新rank的值
代码如下:
#include<bits/stdc++.h>
using namespace std;
//输入:ID Score School
//输出:Rank School TWS Ns
struct institution {
string school_code;
int scoreA, scoreB, scoreT;//scoreX:该机构的某级别的总分
int TWS;//TWS=ScoreB/1.5 + ScoreA + ScoreT*1.5的整数部分
int Ns;//该机构的总人数
};
bool cmp(pair<string, institution>& a, pair<string, institution>& b) {
//排名的方法:TWS从大到小,同分的排名相同,按NS的升序,学校代码的字母表顺序
if (a.second.TWS != b.second.TWS)return a.second.TWS > b.second.TWS;
else if (a.second.Ns != b.second.Ns)return a.second.Ns < b.second.Ns;
else return a.second.school_code < b.second.school_code;
}
int main()
{
int n,score;
string id,school;
cin >> n;
map<string, institution> inslist;
for (int i = 0; i < n; i++) {
cin >> id >> score >> school;
transform(school.begin(), school.end(), school.begin(), ::tolower);
inslist[school].school_code = school;
if (id[0] == 'A')inslist[school].scoreA += score;
else if (id[0] == 'B')inslist[school].scoreB += score;
else if (id[0] == 'T')inslist[school].scoreT += score;
inslist[school].Ns += 1;
}
for (auto it = inslist.begin(); it != inslist.end(); it++) {
it->second.TWS = it->second.scoreB / 1.5 + it->second.scoreA + it->second.scoreT * 1.5;;
}
vector<pair<string, institution>> vec(inslist.begin(), inslist.end());
sort(vec.begin(), vec.end(), cmp);
int rank = 1,tmp=1,lastTWS=vec[0].second.TWS;
cout << vec.size() << endl;
for (auto it = vec.begin(); it != vec.end(); it++,tmp++) {
if (it->second.TWS != lastTWS)rank = tmp;
cout << rank << " " << it->second.school_code << " " << it->second.TWS << " " << it->second.Ns << endl;
lastTWS = it->second.TWS;
}
return 0;
}
运行结果如下: