1100 Mars Numbers (20 分)——(进制转换)

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.
The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

题目大意:

把十进制数转换为火星上的13进制,把13进制转换为10进制。

思路及分析:

先判断输入的数字是是10进制,还是13进制,然后分情况讨论转换,具体看代码。

AC代码:

#include<iostream>
#include<string>
using namespace std;

int main(){
	string s[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
	string s1[13] = {"","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"}; 
	int n;
	cin >> n;
	getchar();
	for(int i = 0; i < n; i++){
		int t;
		if(scanf("%d", &t) == 1){
			if(t < 13) cout << s[t] << endl;
			else if(t % 13 == 0) cout << s1[t/13] << endl;
			else cout << s1[t/13] << ' ' << s[t%13] << endl; 
		}else{
			string str;
			getline(cin, str);
			int j = 0, ans = 0;
			while(str[j] != ' ' && j != str.size()) j++;
			if(j != str.size()) {
				string t = str.substr(0, j);
				string t1 = str.substr(j+1);
				for(j = 1; j <= 13; j++) {
					if(t == s1[j]) {
						ans = j * 13;
						break;
					}
				}
				for(j = 1; j <= 13; j++){
					if(t1 == s[j]) {
						ans += j;
						break;
					}
				}
			}else{
				for(j = 0; j <= 13; j++){
					if(str == s[j]) {
						ans = j;
						break;
					}
				}
				for(j = 1; j <= 13; j++){
	            	if(str == s1[j]){
	            		ans = j*13;
	            		break;
					}
				}
			}
			cout << ans << endl;
		}
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值