1100 Mars Numbers (20分)

这是一篇关于火星数字系统与地球数字系统相互转换的编程题。给定一个正整数N,表示有N个数字需要转换。每个数字要么是地球上的数字,要么是火星上的数字,都在[0, 169)范围内。任务是编写程序实现两种数字系统的互译。" 137718127,16318292,HTML 3D粒子效果实现与代码解析,"['HTML', '3d', '前端']
摘要由CSDN通过智能技术生成

题目

People on Mars count their numbers with base 13:

  • Zero on Earth is called “tret” on Mars.
  • The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.

For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( < 100 ) N(\lt100) N(<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main(){
    int n;
    string text;
    string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
    string b[13] = {"", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
    scanf("%d", &n);
    getchar();
    for(int i=0; i<n; i++){
        getline(cin, text);
        if(text[0] >= '0' && text[0] <= '9'){
            int t = 0;
            for(int j=0; j<text.length(); j++)
                t = t*10 + text[j]-'0';
            int p = t/13, q = t%13;
            if(p == 0){
                printf("%s\n", a[q].c_str());
            }
            else if(q != 0){
                printf("%s %s\n", b[p].c_str(), a[q].c_str());
            }
            else{
                printf("%s\n", b[p].c_str());
            }
        }
        else{
            string t1 = "", t2 = "";
            if(text.length() > 3){
                t1 = text.substr(0, 3);
                t2 = text.substr(4, 7);
            }
            else{
                t2 = text.substr(0, 3);
            }
            int t = 0;
            if(t1 != ""){
                for(int j=1; j<13; j++){
                    if(b[j] == t1){
                        t += j*13;
                        break;
                    }
                }
            }
            if(t2 != ""){
                int k = -1;
                for(int j=0; j<13; j++){
                    if(a[j] == t2){
                        k = j;
                        break;
                    }
                }
                if(k != -1){
                    t += k;
                }
                else{
                    for(int j=1; j<13; j++){
                        if(b[j] == t2){
                            t += j*13;
                            break;
                        }
                    }
                }
            }
            printf("%d\n", t);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值