入门模拟-简单模拟:PAT A1042 Shuffling Machine (20 分)

入门模拟-简单模拟:PAT A1042 Shuffling Machine (20 分)

题目

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题解

1、解法一

没看算法书上面的题解前,自己列举法暴力AC:使用String容器装入54字符串,根据洗牌次数,运用两个字符串来回赋值,这里的来回对调赋值思路很好,不用算法笔记上的next[ ]数组作为中间寄存变量,最后根据洗牌次数选择输出.

#include<iostream>
#include<vector>
#include<string>
using namespace std;
int main()
{
    int n;
    cin >> n ;
    int cnt = n;
    int temp;
    vector<int> vec;
    string str1[54] = {"S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
                      "H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
                      "C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
                      "D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
                     "J1","J2"};
    string str2[54];
    for(int i = 0 ; i < 54 ; i++){
        cin >> temp;
        vec.push_back(temp);
    }

    int flag = 1;
    
    do{
        if(flag == 1){
            for(int i = 0 ;i < 54 ;i++){
                str2[vec[i] - 1] = str1[i];
            }
        }else{
            for(int i = 0 ;i < 54 ;i++){
                str1[vec[i] - 1] = str2[i];
            }
        }
        flag = -flag;
        n--;
    }while(n > 0);
    
    if(cnt % 2 == 0){
        for(int i =0; i < 54 ; i++){
            if(i == 53)
                cout << str1[i];
            else
                cout << str1[i] << " ";
        }
    }else{
        for(int i =0; i < 54 ; i++){
            if(i == 53)
                cout << str2[i];
            else
                cout << str2[i] << " ";
        }
    }
    return 0;
}

2、解法二

关于模拟题,开始想过使用字符数组,但是没有耐心去找寻编号和花色之间的关系,看到题解上面的思路,建立字符数组,编号与花色之间存在:花色 = (编号 - 1) / 13的数量关系,即就是1~13号对应str[0];编号与输出序号之间存在:花色 = (编号 - 1) % 13 + 1的数量关系,即就是1~13号对应输出1-13.

#include<iostream>
using namespace std;
const int N = 54;

int main()
{
    char str[5] = {'S','H','C','D','J'};
    int start[N+1] , end[N+1] , next[N+1];
    int n; 
    cin >> n;
    int temp;
    for(int i = 1; i <= N ;i++){
        start[i] = i;
    }
    for(int i = 1; i <= N ;i++){
        cin >> temp;
        next[i] = temp;
    }
    
    for(int i = 0 ; i < n ;i++){//执行N步洗牌
        for(int i = 1 ; i <= N ; i++){
            end[next[i]] = start[i];
        }
        for(int i = 1; i <= N ; i++){
            start[i] = end[i];
        }
    }
    for(int i = 1; i <= N  ; i++){
        if(i != 1) cout << " ";
        cout << str[(start[i] - 1) / 13] << (start[i] - 1) % 13 + 1;
    }
    return 0;
}

输出末尾没有空格:

以第一个输出为界限,除了第一个不输出空格,其他全部输出.

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

浪漫世界值得孤身qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值