C L1-064 估值一亿的AI核心代码 (20 分)

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know
#include<bits/stdc++.h>
using namespace std;

int main(){
	int n;
	cin >> n;
	cin.ignore();
	string s[n];
	for(int i=0;i<n;i++){
		getline(cin,s[i]);
	}
	for(int i=0;i<n;i++){
		//输出原话 
		cout << s[i] << "\n";
		int l = s[i].size();
		//删除头空格 
		while(s[i][0]==' ')
			s[i].erase(0,1);
		//删除尾空格 
		while(s[i][l-1]==' ')
			s[i].erase(l-1,1);
		
		for(int j=0;j<l;j++){
			//删除标点符号前的空格 
			if(ispunct(s[i][j])!=0&&s[i][j-1]==' ')
				s[i].erase(j-1,1);
			//删除重复多余空格 
			if(s[i][j]==' '&&s[i][j+1]==' '){
				s[i].erase(j,1);
				j--;
			}
			//除I字符小写处理
			if(s[i][j]!='I'&&s[i][j]>='A'&&s[i][j]<='Z'){
				s[i][j] = tolower(s[i][j]);
			} 
		}
		
		//could you,can you---> I could,I can
		int a = s[i].find("could you");
		int b = s[i].find("can you");
		while(a!=-1&&s[i][a+9]==' '){
			s[i].replace(a,9,"I could");
			a = s[i].find("could you");
		}		
		while(b!=-1&&s[i][b+7]==' '){
			s[i].replace(b,7,"I can"); 
			b = s[i].find("can you");
		}
			
		//独立I或me换成you
		int c = s[i].find('I');
		while(c!=-1){
			if(s[i].find("could",c)!=(c+2)&&s[i].find("can",c)!=(c+2)&&(s[i][c+1]==' '||ispunct(s[i][c+1])!=0)){
				s[i].replace(c,1,"you");
				
			}
			c = s[i].find('I',c+1); 	
		}
		int d = s[i].find("me");
		while(d!=-1){
			if(s[i][d+2]==' '&&s[i][d-1]==' '){
				s[i].replace(d,2,"you");
			}
			d = s[i].find("me",d+2);
		}
		
		//?->!
		int e = s[i].find('?');
		while(e!=-1){
			s[i].replace(e,1,"!");
			e = s[i].find('?');
		}
			
		cout << "AI: " << s[i] << "\n";
	}
	return 0;
}

朴实无华的从头写到尾,但测试点1,2,4没通过,求解

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值