判负环:POJ3259 虫洞

这篇博客探讨了一种有趣的时间旅行问题,即农民约翰想要在他的多个农场中利用特殊的虫洞进行时间旅行,返回到出发之前。题目描述了一个包含路径和虫洞的网络,并提出了使用SPFA算法来判断是否存在这样的回路,使得约翰能回到过去。代码示例展示了如何实现SPFA算法以解决这个问题。
摘要由CSDN通过智能技术生成

题目描述:

        While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

        As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

        To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

输入:

Line 1: A single integer, FF farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: NM, and W
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

输出:

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

输入样例:

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

输出样例:

NO
YES

解题思路:

        能否回到过去即为判断负环问题,可以采用SPFA算法快速求解。

SPFA算法:判断负环_可惜浅灰的博客-CSDN博客

代码实现:

#include <iostream>
using namespace std;
#include <queue>
#define maxn 501

int n, m1, m2;
int dis[maxn], sum[maxn];
int head[maxn], cnt;
bool vis[maxn];

class Edge
{
public:
    int to;
    int weight;
    int next;
};
Edge edge[maxn << 1];

void InsertEdge(const int& u, const int& v, const int& w)
{
    edge[++cnt].to = v;
    edge[cnt].weight = w;
    edge[cnt].next = head[u];
    head[u] = cnt;
}

void CreateGraph()
{
    int u, v, w;
    cin >> n >> m1 >> m2;
    for (int i = 1; i <= m1; i++)
    {
        cin >> u >> v >> w;
        InsertEdge(u, v, w);
        InsertEdge(v, u, w);
    }
    for (int i = 1; i <= m2; i++)
    {
        cin >> u >> v >> w;
        InsertEdge(u, v, -w);
    }
}

bool SPFA()
{
    queue<int> q;
    dis[1] = 0;
    q.push(1);
    vis[1] = true;
    sum[1]++;
    while (!q.empty())
    {
        int x = q.front();
        q.pop();
        vis[x] = false;
        for (int i = head[x]; i; i = edge[i].next)
        {
            int v = edge[i].to;
            if (dis[v] > dis[x] + edge[i].weight)
            {
                dis[v] = dis[x] + edge[i].weight;
                if (!vis[v])
                {
                    if (++sum[v] >= n)
                    {
                        return true;
                    }
                    q.push(v);
                    vis[v] = true;
                }
            }
        }
    }
    return false;
}

void Init()
{
    memset(dis, 0x3f3f3f3f, sizeof(dis));
    memset(head, 0, sizeof(head));
    memset(vis, false, sizeof(vis));
    memset(sum, 0, sizeof(sum));
    cnt = 0;
}

int main()
{
    int t;
    cin >> t;
    while (t--)
    {
        Init();
        CreateGraph();
        if (SPFA())
        {
            cout << "YES" << endl;
        }
        else
        {
            cout << "NO" << endl;
        }
    }

    return 0;
}

       

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

可惜浅灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值