字符串反转

一、问题描述

给定字符串s,要求把s中多于一个的连续空压缩成一个空格,并将连续的非空格字符串倒序打印出来,例如,给定”abc def efg”,打印”cba fed gfe”。

输入

abc def efg

输出

cba fed gfe

样例输入 Copy

abc def efg

样例输出 Copy

cba fed gfe

二、完整代码

import java.util.Scanner;
 
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        while (in.hasNext()) {
            String s ="";
            String [] split = in.nextLine().split(" ");
            for(String str : split)
            {
                int strLen = str.length();
                for(int i=1;i<=strLen;i++)
                {
                    s+= str.charAt(strLen-i);
                }
                s += " ";
            }
            s=s.replaceAll(" +"," ");
            System.out.print(s);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值