PTA 1004 成绩排名 (20分)
读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
… … …
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
#include<iostream>
#include<algorithm>
#include<string>
using namespace std; //思路 将姓名 编号 分数用结构体存储;利用sort函数排序分数,
{ //不管是从大到小还是小到到,输出第一个和最后一个储存的结构体数组就是答案
struct student
char name[15];
char num[15];
int score;
};
bool cmp(struct student a,struct student b)
{
return a.score > b.score;
}
int main()
{
int n;
int i=0;
scanf("%d",&n);
struct student stu[10000]; //开大一点不然会段出错
int tmp = n;
while (n--) // 依次输入
{
scanf("%s %s %d",&stu[i].name,&stu[i].num,&stu[i].score);
i++;
}
sort(stu,stu+tmp,cmp); // cmp 是分数从到到小排序的 所以stu[0} 为大;stu[n-1]为最小
cout<<stu[0].name<<" "<<stu[0].num<<endl;
cout<<stu[tmp-1].name<<" "<<stu[tmp-1].num<<endl;
return 0;
}
···