ACM--Lowest Bit

该博客主要介绍了一个程序,用于找出给定正整数的最低位二进制数。例如,对于输入26,其二进制形式为11010,因此最低位是10,输出为2;对于88,二进制形式为1011000,最低位是1000,输出为8。程序通过读取输入,计算二进制表示中1出现的位置,然后根据二进制位权转换为十进制输出结果。
摘要由CSDN通过智能技术生成

Lowest Bit

Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 2729, Accepted users: 2553
Problem 10038 : No special judgement
Problem description
Given an positive integer A (1 <= A <= 109), output the lowest bit of A. For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2. Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 109). A line containing “0” indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26
8
0

Sample Output

2
8

Problem Source

HNU 1’st Contest

#include<iostream>
using namespace std;
int main() {
	int n;
	while(cin>>n,n!=0) {
		int i=-1;//计算到达1前0的个数
		int temp=0;
		while(n) {
			temp=n%2;//取余
			i++;
			n=n/2;
			if(temp==1)
				break;
		}
		temp=1;
		while(i--) {
			temp*=2;//因为格式为1000……所以转化为十进制的话 只与1在哪一位上有关,即是1*2的几次方
		}
		cout<<temp<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

MORE_77

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值