ACM--Adding 1s, 2s, and 3s

Adding 1s, 2s, and 3s

Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 1492, Accepted users: 1394
Problem 10074 : No special judgement

Problem description

Integer 4 can be expressed as a sum of 1s, 2s, and 3s in seven different ways as follows:
1+1+1+1, (1)
1+1+2, (2)
1+2+1, (3)
2+1+1, (4)
2+2, (5)
1+3, (6)
3+1. (7)
Write a program that determines the number of ways in which a given integer can be expressed as a sum of 1s, 2s, and 3s. You may assume that the integer is positive and less than 20.

Input

The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case consists of an integer written in a single line.

Output

Print exactly one line for each test case. The line should contain an integer representing the number of ways.

Sample Input

3
4
7
10

Sample Output

7
44
274

分析

这个题神奇之处在于

存在规律
数字1对应为1
数字2对应为2(1+1,2);
数字3对应为4(1+1+1,2+1,1+2,3);
数字4对应为7……

发现规律:a[n]=a[n-1]+a[n-2]+a[n-3],(n>3);

为了方便,规定a[0]=1

因为题目中说n小于20,所以算到23就够了(其实20就够了)

代码如下:

#include<iostream>
using   namespace  std;
int  a[23] = {1,1,2} ;
void  func() {
	for(int i=3; i<23; i++)
		a[i]=a[i-1]+a[i-2]+a[i-3];
}

int  main() {
	func();
	int t;
	cin>>t;
	while(t--) {
		int n;
		cin>>n;
		cout<<a[n]<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

MORE_77

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值