Adding 1s, 2s, and 3s
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 1492, Accepted users: 1394
Problem 10074 : No special judgement
Problem description
Integer 4 can be expressed as a sum of 1s, 2s, and 3s in seven different ways as follows:
1+1+1+1, (1)
1+1+2, (2)
1+2+1, (3)
2+1+1, (4)
2+2, (5)
1+3, (6)
3+1. (7)
Write a program that determines the number of ways in which a given integer can be expressed as a sum of 1s, 2s, and 3s. You may assume that the integer is positive and less than 20.
Input
The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case consists of an integer written in a single line.
Output
Print exactly one line for each test case. The line should contain an integer representing the number of ways.
Sample Input
3
4
7
10
Sample Output
7
44
274
分析
这个题神奇之处在于
存在规律:
数字1对应为1;
数字2对应为2(1+1,2);
数字3对应为4(1+1+1,2+1,1+2,3);
数字4对应为7……
发现规律:a[n]=a[n-1]+a[n-2]+a[n-3],(n>3);
为了方便,规定a[0]=1
因为题目中说n小于20,所以算到23就够了(其实20就够了)
代码如下:
#include<iostream>
using namespace std;
int a[23] = {1,1,2} ;
void func() {
for(int i=3; i<23; i++)
a[i]=a[i-1]+a[i-2]+a[i-3];
}
int main() {
func();
int t;
cin>>t;
while(t--) {
int n;
cin>>n;
cout<<a[n]<<endl;
}
return 0;
}