HDU-1241 Oil Deposits

        这周系统地学习了一下深度优先搜索(DFS)算法,收获颇丰,以前没什么头绪的迷宫问题,现在遇到简单一点的基本是手到擒来了。

先上题目

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

 

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0 1 2 2

英文题嘛,反正我是看不懂,但是可以找翻译呀。

题目大概就是输入一个图吧,让我们编程实现找到图中有几快“油田”(也就是@表示的范围)需要注意的是,连在一起的@号算一块油田,其实这就是一个简单的DFS算法题,相比于传统的题目,这题需要考虑八个方向,这也基本就是和别的基础题不一样的地方了,话不多说,上代码。

#include <iostream>
using namespace std;
int m, n;
char map[105][105];
void dfs(int x, int y)
{
    int next[8][2] = { { -1,-1 },{ 0,-1 },{ 1,-1 },{ 1,0 },{ 1,1 },{ 0,1 },{ -1,1 },{ -1,0 } }; //考虑八个方向
    if(x < 0 || x > m - 1 || y < 0 || y > n - 1)
        return ;
    map[x][y] = '*';//这里我习惯把用过的点直接表示为不需要选择的那个符号,也可以定义一个1、0的数来标记它。
    for(int i = 0; i < 8; i++)
    {
        int nextx = x + next[i][0];
        int nexty = y + next[i][1];
        if(map[nextx][nexty]=='@')
            dfs(nextx, nexty);//只要能在目标点八个方向找到油田,就继续找下去,直到没有为止。
    }
}
int main()
{
    while(cin >> m >> n && m && n)
    {
        int sum = 0;
        for(int i = 0; i < m; i++)
        {
            for(int j = 0; j < n; j++)
            {
                cin >> map[i][j];
            }
        }
        for (int i = 0; i < m; i++)
        {
            for(int j = 0; j < n; j++)
            {
                if(map[i][j] == '@')
                {
                    int flag = 1;
                    dfs(i, j);
                    sum++;
                }
            }
        }
        cout << sum << endl;
    }
    return 0;
}

对于简单的DFS算法,确实没什么难度,今天稍微看了一下BFS算法,有点脑壳疼,下周继续加油。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值