学习笔记(位运算(1))

位运算(加dp)**

E - The Number of set
HDU - 3006

Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
Output
For each case,the output contain only one integer,the number of the different sets you get.
Sample Input
4 4
1 1
1 2
1 3
1 4
2 4
3 1 2 3
4 1 2 3 4
Sample Output
15
2

主要运用‘|’运算符。
用二进制来储存集合,把某数用二进制对应的位上的一来表示,例如1,3就用101,如果两个集合合并就用’|’,
例如:集合1,3,5和3,4,5就是10101和11100进行’|'运算,结果是11101.


#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
#include <stack>
#include <cstring>
#include <cstdio>
#include <queue>
#include <map>
#define endl "\n"
#define Buff std::ios::sync_with_stdio(false), cin.tie(0), cout.tie(0)
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
const int maxn = 1e5 + 5;
ll t, n, m;
ll ans;
ll dp[1 << 15], b[15], a[110];
int main()
{
    Buff;
    b[0] = 1;
    for (int i = 1; i <= 15; i++)
        b[i] = b[i - 1] << 1;
    while (cin >> n >> m)
    {
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        ans = 0;
        for (int i = 0; i < n; i++)
        {
            a[i] = 0;
            cin >> t;
            for (int j = 0; j < t; j++)//记录集合
            {
                ll x;
                cin >> x;
                a[i] = a[i] | b[x - 1];
            }
        }
        for (int i = 0; i < n; i++)
            for (int j = b[m] - 1; j >= 0; j--)//对集合进行合并
                if (dp[j])
                    dp[j | a[i]] = 1;
        for (int i = b[m]-1; i > 0; i--)
            if (dp[i])
                ans++;
        cout << ans << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值