1054 求平均值 (20 分)
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is Y
。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
对于这个题,是我目前为止花了最长时间的一个题,现在回想,是真有点搞人心态。对于输出,一个数合法的时候是单数number,其他情况则是numbers,一开始没认真看题,全部输出numbers,又检查了半天,但最后我自己写的代码只通过了三个测试数据,还有一个怎么也通不过。
最后看了别人的博客,他发了柳神的代码,不得不说sscanf和sprintf函数在处理一些字符串的时候,真的作用很大。
我最后看了别人的博客,写了三个代码,总结出了几点:
- 对于相对比较复杂一点的情况,还是写一个函数比较好,很多相同的情况都可以合并,就比如说,这个题,把不符合题意的数据返回false,其他就返回true。而全部在主函数中写,就有可能会漏写,第一个代码开始我就漏写了最里面的if语句,没有考虑大于1000或者小于-1000的情况。
- else if(flag==1)
{
double dou=str_dou(str);
if(i-j<=3)
{
if(dou>=-1000&&dou<=1000)
{
++count;
average+=dou;
}
else
ans.push_back(str);
} - 能用string就用string,不要用传统c字符串,因为有时候我们根本不知道要用多大的字符串,也拿这题举例。这题一开始我用了大小为20的字符数字,想着20肯定能装下每一个数据吧,结果有一组数据不能通过,百思不得其解,最后改了数组大小为50才通过。小心脏顿时受不了了。
- 虽然仅仅这一个题费了我不少时间,但也是值得了,毕竟收获了一些东西。在最后改我之前那个代码,提交看见全部正确的时候,一股喜悦之情涌上心头。
话不多说,放码过来!!!
这是我最先写的,开始不是正确了,后面改正确了。现在一看,确实挺复杂了。
#include <iostream>
#include <vector>
#include <string>
#include <cstdio>
using namespace std;
double str_dou(string s);
int main()
{
int n;
cin >> n;
string str;
double average=0;
int count=0; //count统计合法数据
vector<string> ans; //ans存储不合法数据
while(n--)
{
cin >> str;
int i,j=0, flag=0; //j和flag分别记录小数点的位置和个数
for(i=0;i<str.size();i++)
{
if(str[i]=='-')
{
if(i!=0)
{
ans.push_back(str);
break;
}
}
if(str[i]=='.')
{
j=i;
flag++;
}
if(!isdigit(str[i])&&str[i]!='.'&&str[i]!='-')
{ //如果是除了小数点或负号以外的非数字符号
ans.push_back(str);
break;
}
}
if(i==str.size())
{
if(flag==0)
{
double dou=str_dou(str);
if(dou>=-1000&&dou<=1000)
{
++count;
average+=dou;
}
else
ans.push_back(str);
}
else if(flag==1)
{
double dou=str_dou(str);
if(i-j<=3)
{
if(dou>=-1000&&dou<=1000)
{
++count;
average+=dou;
}
else
ans.push_back(str);
}
else
{
ans.push_back(str);
}
}
else
{
ans.push_back(str);
}
}
}
for(int i=0;i<ans.size();++i)
{
printf("ERROR: %s is not a legal number\n",ans[i].c_str());
}
if(count==1)
printf("The average of %d number is %.2f\n",count,average);
else if(count>1)
printf("The average of %d numbers is %.2f\n",count,average/count);
else
printf("The average of %d numbers is Undefined\n",count);
return 0;
}
double str_dou(string s)
{
double dou=0,pos=0.1;
int flag=1,judge=1;
for(auto a:s)
{
if(a=='-')
{
judge=-1;
continue;
}
if(a=='.')
{
flag=0;
continue;
}
if(flag)
dou=dou*10+a-'0';
else
{
dou+=(a-'0')*pos;
pos*=0.1;
}
}
dou*=judge;
return dou;
}
这是把所有情况单独写的一个函数,怎么说,感觉比之前那个要好一点。
#include <iostream>
#include <vector>
#include <string>
#include <cstdio>
using namespace std;
double str_dou(string s);
bool judge(string str);
int main()
{
int n;
cin >> n;
string str;
double average=0;
int count=0;
while(n--)
{
cin >> str;
if(!judge(str))
printf("ERROR: %s is not a legal number\n",str.c_str());
else
{
average+=str_dou(str);
++count;
}
}
if(count==1)
printf("The average of %d number is %.2f\n",count,average);
else if(count>1)
printf("The average of %d numbers is %.2f\n",count,average/count);
else
printf("The average of %d numbers is Undefined\n",count);
return 0;
}
double str_dou(string s)
{
double dou=0,pos=0.1;
int flag=1,judge=1;
for(auto a:s)
{
if(a=='-')
{
judge=-1;
continue;
}
if(a=='.')
{
flag=0;
continue;
}
if(flag)
dou=dou*10+a-'0';
else
{
dou+=(a-'0')*pos;
pos*=0.1;
}
}
dou*=judge;
return dou;
}
bool judge(string str)
{
int i,j=0, flag=0;
for(i=0;i<str.size();i++)
{
if(str[i]=='-')
{
if(i!=0)
return false;
}
if(str[i]=='.')
{
j=i;
flag++;
}
if(!isdigit(str[i])&&str[i]!='.'&&str[i]!='-')
return false;
}
if(flag>1)
return false;
else if(flag==1)
{
if(i-j>3)
return false;
double dou=str_dou(str);
if(dou<-1000||dou>1000)
return false;
}
else
{
double dou=str_dou(str);
if(dou<-1000||dou>1000)
return false;
}
return true;
}
最后就是看了柳神的代码,写出来的。
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cmath>
using namespace std;
int main()
{
int n;
scanf("%d",&n);
char s[50],ans[50];
double db;
int count=0;
double average=0;
while(n--)
{
cin >> s;
sscanf(s,"%lf",&db);
sprintf(ans,"%.2f",db);
int len=strlen(s);
int flag=0;
for(int i=0;i<len;++i)
{
if(s[i]!=ans[i])
{
flag=1;
break;
}
}
if(flag==1||db>1000||db<-1000)
{
printf("ERROR: %s is not a legal number\n",s);
}
else
{
average+=db;
++count;
}
}
if(count==1)
printf("The average of %d number is %.2f\n",count,average);
else if(count>1)
printf("The average of %d numbers is %.2f\n",count,average/count);
else
printf("The average of %d numbers is Undefined\n",count);
return 0;
}