PAT A1002 A+B for Polynomials

1002 A+B for Polynomials

分数 25

作者 CHEN, Yue

单位 浙江大学

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

Please be accurate to 1 decimal place.

请将结果保留一位小数,decimal不止只有十进制的意思,还有小数的意思,甲级对英语不好的人来说真的很不友好啊。

考察Two Point ( 双指针)的运用:

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

typedef pair<int,double> PID;

const int maxn = 15;
PID A[maxn] , B[maxn], res[maxn];
int idx;

int main()
{
    int n, m;
    cin >> n;
    for(int i=0;i<n;++i)
        cin >> A[i].first >> A[i].second;
    
    cin >> m;
    for(int i=0;i<m;++i)
        cin >> B[i].first >> B[i].second;
    
    int i=0, j=0;
    while(i < n && j < m)
    {
        if(A[i].first > B[j].first) //A的最高次的指数比B的最高次的指数大
            res[idx++] = A[i++];
        
        //B的最高次的指数比B的最高次的指数大
        else if(A[i].first < B[j].first) 
            res[idx++] = B[j++];
        
        //A和B的最高次的指数一样大,进行项数合并
        else
        {
            double coe = A[i].second + B[j].second;
            //注意系数为0的项直接去掉
            if(coe != 0)
                res[idx++] = {A[i].first , coe};
            ++i,++j;
        }
    }
    
    while(i < n)
        res[idx++] = A[i++];
    while(j < m)
        res[idx++] = B[j++];
         
    cout << idx;
    
    int flag = 1;
    for(int i=0;i<idx;++i)
    {
        if(i == 0)
            cout << ' ';
        if(res[i].second != 0)
        {
            if(flag)
                flag = 0;
            else
                cout << ' ';
            
            //注意结果是保留一位小数,特别注意
            printf("%d %.1f",res[i].first,res[i].second);
        }
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值