PAT A1046 Shortest Distance

该程序解决的问题是,给定一个形成简单循环的高速公路出口,计算任意两个出口之间的最短距离。通过输入的各出口间的距离,利用前缀和计算每个出口到起点的距离,然后找出两个出口间最短路径。代码中使用了交换变量的方法来处理输入的出口顺序可能相反的情况。
摘要由CSDN通过智能技术生成

1046 Shortest Distance

分数 20

作者 CHEN, Yue

单位 浙江大学

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1​ D2​ ⋯ DN​, where Di​ is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

 * 考察前缀和;
 * s[i] 表示 是起点1到第i点的距离;
 *
 * 求l到r的最短距离:
 * l到r的距离为 d = s[r] - s[l], 求最短距离就是求 min(d, s[n+1] - d) 的值;
 *
 * 注意,当输入的 l > r 的时候,交换两个数的值,以便统一处理;

/**
 * 考察前缀和;
 * s[i] 表示 是起点1到第i点的距离;
 * 
 * 求l到r的最短距离:
 * l到r的距离为 d = s[r] - s[l], 求最短距离就是求 min(d, s[n+1] - d) 的值;
 * 
 * 注意,当输入的 l > r 的时候,交换两个数的值,以便统一处理;
*/

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long LL;
const int N = 1e5 + 10;
LL s[N];

int main()
{
    int n;
    cin >> n;
    
    int sum = 0;
    for(int i=2; i<=n+1; ++i) //注意i是从2开始的,因为第一个数据是1到2的距离
    {
        int d;
        cin >> d;
        s[i] = s[i-1] + d;
    }
    
    int m;
    cin >> m;
    while (m -- )
    {
        int l, r;
        cin >> l >> r;
        if(l > r)
            swap(l ,r);
        
        LL d = s[r] - s[l];
        cout << min(d, s[n+1] - d) << endl;
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks. Input Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Inputcopy Outputcopy 25 5 2 2 14 11 21 17 4 Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
07-24
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值