PAT A1112 Stucked Keyboard

1112 Stucked Keyboard

分数 20

作者 CHEN, Yue

单位 浙江大学

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

 

用一个hs数组记录每个键的好坏,好键记录为true,否则为false,先遍历
 * 整个字符串,如果是好键记录为true,否则为false,为什么不将坏键记录
 * 为true,因为即使前面的某个子字符串有连续的K个相同字符,那也不能确定
 * 此字符就为坏键,因为可能后面会出现不是k个连续的此字符;
 * 因此先统计好键,然后再遍历一遍字符串,好键直接输出,坏键输出一个字符;

/**
 * 用一个hs数组记录每个键的好坏,好键记录为true,否则为false,先遍历
 * 整个字符串,如果是好键记录为true,否则为false,为什么不将坏键记录
 * 为true,因为即使前面的某个子字符串有连续的K个相同字符,那也不能确定
 * 此字符就为坏键,因为可能后面会出现不是k个连续的此字符;
 * 因此先统计好键,然后再遍历一遍字符串,好键直接输出,坏键输出一个字符;
*/

#include <iostream>
#include <string>
#include <map>

using namespace std;

string press, res;
const int N = 128;
bool hs[N];
map<char, int> mp;

int main()
{
    int k;
    cin >> k;
    string s;
    cin >> s;
    
    int len = s.size();
    for(int i=0; i<len; ++i)
    {
        int j = i, cnt = 1;
        char ch = s[i];
        
        //连续的字符ch
        while(j+1 < len && s[j+1] == ch)
        {
            ++cnt;
            ++j;
            
            //有连续的k个字符ch了则直接退出循环
            if(cnt == k) 
            {
                i = j;
                break;
            }
        }
        
        //如果可能是坏键,则进行下一轮循环
        if(cnt == k && hs[ch] == 0) 
            continue;
        hs[ch] = 1; //
    }
    
    for(int i=0; i<len; ++i)
    {
        int j = i, cnt = 1;
        char ch = s[i];
        
        while(j+1 < len && s[j+1] == ch)
        {
            ++cnt;
            ++j;
            
            if(cnt == k) 
                break;
        }
        
        if(cnt == k && hs[ch] == 0) 
        {
            if(mp[ch] != 1)
            {
                press.push_back(ch);
                mp[ch] = 1;
            }
            i = j;
        }
        res += ch;
    }
    
    cout << press << endl;
    cout << res << endl;
    
    return 0;
    
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值