PAT甲级1112 Stucked Keyboard

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.
Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.
Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest

思路

感谢评论区@嗯你还好吗 的指正,之前一直卡在测试点1、2,原先的做法让_默认是正确的,只有字母会出错。实际上_也会出错

#include <iostream>
#include <string>
#include <map>
#include <vector>
using namespace std;
map<char, bool> rightKey; //记录好键
map<char, bool> wrongKey; //记录坏键
int main()
{
	int k;
	string str, record = "";
	cin >> k >> str;
	for (int i = 0; i < str.size(); i++)
	{
		int j = i;
		//j用来探查后面的元素是否和当前字符相同
		while (j + 1 < str.size() && str[j + 1] == str[i])
			j++;
		//如果个数为k的倍数说明是坏键
		if ((j - i + 1) % k == 0)
		{
			if (rightKey[str[i]] == false && wrongKey[str[i]] == false)
			{
				wrongKey[str[i]] = true;
				record += str[i];
			}
		}
		else //不是k的倍数是好键
		{
			rightKey[str[i]] = true;
			//如果原先将该键设为过坏键,则改正过来
			if (wrongKey[str[i]] == true)
			{
				wrongKey[str[i]] = false;
				record.erase(record.find(str[i]), 1);
			}
		}
		i = j; //i跳到j的位置
	}
	cout << record << endl;
	for (int i = 0; i < str.size(); i++)
	{
		cout << str[i];
		if (!rightKey[str[i]])
			i += k - 1;
	}
	
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值