PAT A1161 Merging Linked Lists

1161 Merging Linked Lists

分数 25

作者 陈越

单位 浙江大学

Given two singly linked lists L1​=a1​→a2​→⋯→an−1​→an​ and L2​=b1​→b2​→⋯→bm−1​→bm​. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1​→a2​→bm​→a3​→a4​→bm−1​⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1​ and L2​, plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

 将链表节点用静态数组存储,每个结点用一个结构体来存储,输入所有
 * 节点后,将两个链表的结点分别用两个vector来存储;最后输出即可,
 * 但是要注意每个结点的next值,因为是两个链表穿插输出,所以每个结点
 * 的next值要注意一下;

/**
 * 将链表节点用静态数组存储,每个结点用一个结构体来存储,输入所有
 * 节点后,将两个链表的结点分别用两个vector来存储;最后输出即可,
 * 但是要注意每个结点的next值,因为是两个链表穿插输出,所以每个结点
 * 的next值要注意一下;
*/

#include <iostream>
#include <vector>

using namespace std;

struct Node
{
    int add, dat, nex;
};

const int N = 1e5+10;
struct Node a[N];
vector<Node> vec1, vec2;

int main()
{
    int h1, h2, n;
    cin >> h1 >> h2 >> n;
    for(int i=0; i<n; ++i)
    {
        int add, dat, nex;
        cin >> add >> dat >> nex;
        a[add] = {add, dat, nex};
    }
    
    while(h1 != -1)
    {
        vec1.push_back(a[h1]);
        h1 = a[h1].nex;
    }
    
    while(h2 != -1)
    {
        vec2.push_back(a[h2]);
        h2 = a[h2].nex;
    }
    
    if(vec1.size() < vec2.size())
        swap(vec1, vec2);
    
    for(int i=0, j=vec2.size()-1; i<vec1.size(); ++i)
    {
        auto ele = vec1[i]; 
        if(i != vec1.size()-1 || j == 0) //输出第一个链表的结点
        {
            //只有第二链表还有结点没有输出,才将该结点的next值输出为
            //vec2[j]的add值,
            if((i + 1) % 2 == 0 && j >= 0) 
                printf("%05d %d %05d\n", ele.add, ele.dat, vec2[j].add);
            else
                printf("%05d %d %05d\n", ele.add, ele.dat, ele.nex);
        }
        else
            printf("%05d %d -1\n", ele.add, ele.dat); 
            //表示两个链表的最后一个节点
            
        ele = vec2[j];
        if((i+1) % 2 == 0 && j>= 0) 
        {
            if(i != vec1.size() - 1)
                printf("%05d %d %05d\n", ele.add, ele.dat, vec1[i+1].add);
            else
                printf("%05d %d -1\n", ele.add, ele.dat);
                //表示两个链表的最后一个节点
            --j;
        }
    }
    
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值