PAT 1161 Merging Linked Lists

该博客介绍了一个编程问题,涉及到对两个已知长度的单链表进行操作。具体任务是如果一个链表的长度至少是另一个的两倍,将较短的链表反转并插入到较长链表中,使得结果链表交替包含原链表的节点。提供的C++代码实现了这一操作,首先反转较短链表,然后逐个插入到较长链表的适当位置。
摘要由CSDN通过智能技术生成

1161 Merging Linked Lists (25 分)

Given two singly linked lists L1​=a1​→a2​→⋯→an−1​→an​ and L2​=b1​→b2​→⋯→bm−1​→bm​. If n≥2m, you are supposed to reverse and merge the shorter one into the longer one to obtain a list like a1​→a2​→bm​→a3​→a4​→bm−1​⋯. For example, given one list being 6→7 and the other one 1→2→3→4→5, you must output 1→2→7→3→4→6→5.

Input Specification:

Each input file contains one test case. For each case, the first line contains the two addresses of the first nodes of L1​ and L2​, plus a positive N (≤105) which is the total number of nodes given. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is a positive integer no more than 105, and Next is the position of the next node. It is guaranteed that no list is empty, and the longer list is at least twice as long as the shorter one.

Output Specification:

For each case, output in order the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 01000 7
02233 2 34891
00100 6 00001
34891 3 10086
01000 1 02233
00033 5 -1
10086 4 00033
00001 7 -1

Sample Output:

01000 1 02233
02233 2 00001
00001 7 34891
34891 3 10086
10086 4 00100
00100 6 00033
00033 5 -1

思路:

先将小的链表反转,然后再每隔两个长链表节点插入一个短链表节点 

#include<bits/stdc++.h>
using namespace std;
#define ll long long
int a[100005];
int nex[100005];
int listreverse(int hd)
{
	int pre = -1;
	int now = hd;
	while (now != -1)
	{
		int nx = nex[now];
		nex[now]=pre;
		pre = now;
		now = nx;
	}
	return pre;
}
int main()
{
	int hd1, hd2;
	int n; cin >> hd1>>hd2>>n;
	for (int i = 1; i <= n; ++i)
	{
		int x;
		cin >> x;
		cin>> a[x] >> nex[x];
	}
	int n1=0;
	int n2 = 0;
	for (int i = hd1; i != -1; i = nex[i])
	{
		n1++;
	}
	for (int i = hd2; i != -1; i = nex[i])
	{
		n2++;
	}
	if (n1 < n2)
	{
		swap(hd1, hd2);
		swap(n1, n2);
	}
	hd2=listreverse(hd2);
	int now1 = hd1;
	int now2 = hd2;
	int cnt = -1;
	while(now1 != -1)
	{
		cnt++;
		int nx = nex[now1];
		if (cnt % 2 == 1)
		{
			if (now2 != -1)
			{
				int nx2 = nex[now2];
				nex[now2] = nex[now1];
				nex[now1] = now2;
				now2 = nx2;
			}
		}
		now1 = nx;
	}
	for (int i = hd1; i != -1; i = nex[i])
	{
		if (nex[i] == -1) printf("%05d %d %d\n", i, a[i], nex[i]);
		else printf("%05d %d %05d\n", i, a[i], nex[i]);
	}
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值