PTA——01-复杂度2 Maximum Subsequence Sum (25 分)(C++题解)

题目描述 :

Given a sequence of K integers { N​1​​ , N​2​​ , …, N​K​​ }. A continuous subsequence is defined to be { Ni​​ , Ni+1​​ , …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21 
Sample Output:
10 1 4

我的思路 :

首先呢拿到这道题肯定知道是一道小小的动态规划,这应该是一道很经典的动规题了,之前有一道是只输出 最大子列和 即可,这道题有多让你输出两个数据:子列的 起始值终点值 。那么最大子列和的计算方法就是 :“ 在线处理 ”

首先点定义一个ThisSum代表每输入一个数字,就进行加和,再定义一个MaxSum表示目前最大子列的和;接着每输入一个数字a[i],先让ThisSum加上a[i],当ThisSum小于0的时候,显然我们就不需要这一串序列的和ThisSum,如果大于0的话呢,我们比较ThisSum和MaxSum的大小,若ThisSum > MaxSum 就 MaxSum = ThisSum;

那怎么进行标记序列的起点和终点呢?
每当 ThisSum < 0 被舍去时,这时候就得到了一个新的子列的起点,我们对这个起点进行标记 count = i+1;
否则,当 ThisSum > MaxSum 时我们得到了目前最大子列的一个新的终点,
这时候我们让pos1 = count, pos2 = i,来更新我们子列的起点和终点。

运行时可得到以下运行顺序:

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

代码如下 :

# include <iostream>
using namespace std;
const int MAXN = 7+10e4;

int main(void)
{
    int n;
    int num, a[MAXN];
    int pos1 = 0, pos2 = 0;
    int count = 0;
    int ThisSum = 0, MaxSum = -1;
    cin >> n;
    pos2 = n-1;
    for(int i = 0; i < n; i++){
        cin >> a[i];
        ThisSum += a[i];
        if(ThisSum < 0){
                ThisSum = 0;
                count = i+1;
            }
        else if(ThisSum > MaxSum){
            MaxSum = ThisSum;
            pos1 = count;
            pos2 = i;
        }
        
    }
    if(MaxSum < 0) MaxSum = 0;

    cout << MaxSum << ' ' << a[pos1] << ' ' << a[pos2];

    system("pause");
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值