PTA 01-复杂度2 Maximum Subsequence Sum (25 分)

01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

我这渣渣英语,真的。。。。搞了一早上,以为输出的是:最大序列和 下标 下标;其实,输出的是:最大序列和 下标对应的值 下标对应的值。

这个里面注意的是,如果全部是负数,应该输出0 a[0] a[n-1],如果有负数有0,应该输出0 0 0

具体思路:设置一个flag,如果在向后加序列的时候出现和为负数,那就从头开始加,开头的下标就要从下一个下标开始,然后每次符合要求都记录这次的start和end

#include <stdio.h>
int main()
{
    int n, i, flag=0;
    scanf("%d", &n);
    int a[n];
    for(i=0;i<n;i++){
        scanf("%d", &a[i]);
    }
    int maxNum=0,ThisNum=0, start=0, Thisstart=0, end=n-1;
    
    for(i=0;i<n;i++){
        ThisNum+=a[i];
        if(flag==1){
            Thisstart=i;
            flag=0;
        }
        if(ThisNum>maxNum ||(ThisNum>=maxNum && maxNum==0)){
            // 符合条件
            // ThisNum>=maxNum && maxNum==0 这个是为了保证有负数有0的时候输出0 0 0
            maxNum=ThisNum;
            start = Thisstart;
            end = i;
        }
        else if(ThisNum<0){
            // 不符合条件
            flag=1;
            ThisNum=0;
        }
    }
    
    printf("%d %d %d", maxNum, a[start], a[end]);
    return 0;
}
/*
10
-10 1 2 3 4 -5 23 3 7 -21
10
-10 -1 -2 -1 0 -5 -23 -3 -7 -21
 */
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
题目描述 给定K个整数组成的序列{ N1, N2, ..., NK },“连续子列”被定义为{ Ni, Ni+1, ..., Nj },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{-2, 11, -4, 13, -5, -2},其最大子列和为20,对应子列为{ 11, -4, 13 }。 现在你应该给出一个算法,计算给定整数序列的最大子列和。 输入格式 输入第1行给出正整数K(K≤10000),第2行给出K个整数,其间以空格隔。 输出格式 在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出。 输入样例 6 -2 11 -4 13 -5 -2 输出样例 20 算法1 (暴力枚举) $O(n^2)$ 暴力枚举所有的子序列,计算它们的和,最后找到最大的和即可。 时间复杂度 枚举所有子序列,时间复杂度为$O(n^2)$。 C++ 代码 算法2 (治) $O(nlogn)$ 将序列成左右两部,最大子序列和可能在左边、右边或者跨越中间。如果最大子序列和在左边或者右边,那么可以递归求解;如果最大子序列和跨越中间,那么可以别求出左边的最大后缀和和右边的最大前缀和,然后将它们相加即可。 时间复杂度 每次递归都会将序列成两部,时间复杂度为$O(logn)$,而每次计算跨越中间的最大子序列和的时间复杂度为$O(n)$,所以总的时间复杂度为$O(nlogn)$。 C++ 代码 算法3 (动态规划) $O(n)$ 用dp[i]表示以i结尾的最大子序列和,那么dp[i]的值可以由dp[i-1]和a[i]计算得到。如果dp[i-1]是负数,那么dp[i]就是a[i];否则dp[i]就是dp[i-1]+a[i]。最后找到dp数组中的最大值即可。 时间复杂度 只需要遍历一遍数组,时间复杂度为$O(n)$。 C++ 代码

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值