问题:给一组参数,每个参数两个数据,按照第一个数据严格减小,第二个数据严格增大求出满足条件的最长参数长度,并输出其输入时的序号。
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7
#include <iostream>
#include <algorithm>
using namespace std;
struct mouse
{
int w,v,xh;
}s[1001];
bool cmp(mouse a,mouse b)
{
if(a.w!=b.w)
return a.w>b.w;
else
return a.v<b.v;
}
int main()
{
int i=1;
while(cin>>s[i].w>>s[i].v)
{
s[i].xh=i;
i++;
}
int n=i-1;
sort(s+1,s+1+n,cmp);
int dp[1001]={0},path[1001]={0},m=0,id=0;
for(int j=0;j<=n;j++)
path[j]=j;
for(int j=1;j<=n;j++)
{
for(int t=1;t<j;t++)
{
if(s[j].w<s[t].w&&s[j].v>s[t].v&&dp[j]<dp[t]+1)
{
dp[j]=dp[t]+1;
path[j]=t;//用数组path[]储存每个参数对应的前一个参数,用于输出序列,很好用。
}
else
continue;
}
if(dp[j]+1>m)
{
m=dp[j]+1;
id=j;
}
}
cout<<m<<endl;
cout<<s[id].xh<<endl;
while(id!=path[id])
{
cout<<s[path[id]].xh<<endl;
id=path[id];
}
}