V - Binary Tree Traversals HDU - 1710

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output
For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1
第一个二叉树题
注意建法,proot=(Node)calloc()才可以修改,而这里不需要哨兵节点
注意递归,先终止项,再继续项

#include<stdio.h>
#include<stdlib.h>
#define N 1005
int pre[N],in[N]; 
int n,i;
typedef struct node{
	int value;
	struct node*pl,*pr;
}Node;
void build(int a,int b,int len,Node*proot){
	//处理该点
	proot->value=pre[a];//注意不是scanf 
	if(len==1){
		return;
	}
	int cnt;
	for(cnt=0;pre[a]!=in[b+cnt];cnt++);
	if(cnt){
		proot->pl=(Node*)calloc(1,sizeof(Node));
		build(a+1,b,cnt,proot->pl);
	}
	if(len-cnt-1){
		proot->pr=(Node*)calloc(1,sizeof(Node));
		build(a+cnt+1,b+cnt+1,len-cnt-1,proot->pr);
	}
}
void post(Node*proot,int flag){
	if(!proot->pl&&!proot->pr){
		printf("%d",proot->value);
		if(flag)printf(" ");
		return;
	}
	if(proot->pl){
		post(proot->pl,1);
	}
	if(proot->pr){
		post(proot->pr,1);
	}
	printf("%d",proot->value);
	if(flag)printf(" ");
}
int main()
{
	while(~scanf("%d",&n)){ 
		Node*proot=(Node*)calloc(1,sizeof(Node));//注意要直接有一个头 
		for(i=1;i<=n;i++){
			scanf("%d",&pre[i]);
		}
		for(i=1;i<=n;i++){
			scanf("%d",&in[i]);
		}
		build(1,1,n,proot);
		post(proot,0);
		printf("\n"); 
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值