Hello,world!

##Hello,world!
|

题目描述

This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

输入

The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

输出

Output the corresponding message. Note there is NOT a newline character in the end of output.

样例输入

72 101 108 108 111 44 32 119 111 114 108 100 33

样例输出

Hello,world!

代码

#include<stdio.h>
int main()
{

    char a[100];
    int t;
     int i=0;
      while(scanf("%d",&t)!=EOF)
    {
        a[i]=t;
        printf("%c",a[i]);
        i++;
    }
    return 0;
}



思路

先创建一个字符数组,因为数字不能直接给字符型变量赋值,故用一个中间变量t来给字符型元素a[i] 赋值。因为输入的个数不确定,类似于之前做过的:

char ch;
while((ch=getchar())!='\n')
{...}

我们可以用一个

while(scanf("%d",&t)!=EOF)

来实现持续输入
*[HTML] :从Hello,world!开始,记录刷题历程。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值