poj 1163(记忆化搜索)入门

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output

30

写道例题了解下记忆化搜索
在dp过程中,有的状态dp[i][j]可能会重复运行很多次,如果我们加个条件限制,就可以避免重复计算,如果仔细看看的话,会发现优化能力是惊人的

详细看代码

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
int a[150][150],n;
int dp[150][150];
int dfs(int i,int j){
    if(i==n)
        return a[n][j];
    if(dp[i][j]>=0)//记忆化搜索,如果大于0,即此状态遍历过,避免重复遍历
        return dp[i][j];
    else
        return dp[i][j]=a[i][j]+max(dfs(i+1,j),dfs(i+1,j+1));
}
int main()
{
    memset(dp,-1,sizeof(dp));
    cin>>n;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=i;j++){
            cin>>a[i][j];
        }
    }
    for(int i=1;i<=n;i++)  dp[n][i]=a[n][i];
    dfs(1,1);
    cout<<dp[1][1];
    return 0;
}

制定自己的计划,认真按时间执行,我想变得更好。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值