1115 Counting Nodes in a BST (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

结尾无空行

Sample Output:

2 + 4 = 6

结尾无空行

#include<iostream>
using namespace std;
typedef struct node{
    int data;
    struct node*left,*right;
}*BST;
int num[10005];
void insertBST(BST &root,int value)      //传入值
{
    if(root==NULL)
    {
        root=new node;       		//创建新的节点,往里面插入 
        root->data=value;
        root->left=NULL;
        root->right=NULL;
    }else {
        if(value>root->data)insertBST(root->right,value);    //如果大于根节点数值 就递归放在右子树
        if(value<=root->data)insertBST(root->left,value);    //如果小于等于结点的数值 就递归放在左子树 
    }
}
            //建立树完毕,查找最下面一层与倒数第二层结点的数目
            //用num数组存放当前层次的结点数量 
void dfs(int cur,BST root)		//根节点数目为1  
{
    if(root==NULL)
        return ;
    num[cur]++;		
    dfs(cur+1,root->left);		//你的小弟的cur就是你的cur+1 ,因此num存放的就是每一层的结点总数 
    dfs(cur+1,root->right);
}
int main()
{
    int N,a,value;
    cin>>N;
    BST root=NULL;
    for(int i=1;i<=N;i++)
    {
        cin>>value;
        insertBST(root,value);		//因为根节点是不动的 所以返回值是void 
    }
    dfs(1,root);
    int flag;
    for(int i=1;i<5000;i++)		//
    {
        if(num[i]==0)
        {
            flag=i;
            break;
        }
    }
    cout<<num[flag-1]<<" + "<<num[flag-2]<<" = "<<num[flag-1]+num[flag-2];
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值