1063 Set Similarity (25 分)

Given two sets of integers, the similarity of the sets is defined to be Nc​/Nt​×100%, where Nc​ is the number of distinct common numbers shared by the two sets, and Nt​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

结尾无空行

Sample Output:

50.0%
33.3%

结尾无空行

#include<iostream>
#include<set>
#include<stdio.h>
using namespace std;
set<int>s[2005];
set<int>temp;
set<int>::iterator it1,it2;
int main()
{
    //如果直接用(遍历子集合放到temp集合中)来判断有多少重复的会超时
    //因此用双指针来做
    int N,K,a,b,c,d;
    cin>>N;
    for(int i=1;i<=N;i++)
    {
        cin>>a;
        while(a--)
        {
            cin>>b;
			s[i].insert(b);
        }
        
    }
    cin>>K;
    for(int i=1;i<=K;i++)
    {
    	if(i!=1)cout<<endl;
        int same_num=0;
        cin>>a>>b;
        for(it1=s[a].begin(),it2=s[b].begin();it1!=s[a].end()&&it2!=s[b].end();)
        {
            //如果相等就两个都向前 否则谁小谁向前走
            if(*it1==*it2){
                it1++,it2++;
                same_num++;
            }else if(*it1>*it2)
            {
                it2++;
            }else it1++;
        }
        int Nt=s[a].size()+s[b].size()-same_num;
        double rate=100.0*same_num/Nt;
        printf("%.1lf%c",rate,'%');
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值