L1-062 幸运彩票 (15 分)
彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。
输入格式:
输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。
输出格式:
对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!
;否则输出 Wish you good luck.
。
输入样例:
2
233008
123456
输出样例:
You are lucky!
Wish you good luck.
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<sstream>
using namespace std;
typedef long long ll;
const int N=10010;
int main()
{
int n;
cin >> n;
while(n -- )
{
string a;
cin >> a;
int x = 0, y = 0;
for(int i = 0; i < a.size(); i ++ )
{
if(i < 3) x += a[i] - '0';
else y += a[i] - '0';
}
if(x == y) cout << "You are lucky!" << endl;
else cout << "Wish you good luck." << endl;
}
return 0;
}