ZZULIOJ 1196: 数星星(二)(结构体专题),Java

ZZULIOJ 1196: 数星星(二)(结构体专题),Java

题目描述

一天,小明坐在院子里数星星,Gardon就出了个难题给他,让他数数天上的星星最多有多少个是在同一条直线上的。天上的星星太多了,小明马上就看花了眼,你能写个程序来帮他计算么?

输入

首先输入一个整数N(N<=300),接下来的N对数每对表示一个星星的位置(星星的坐标在-10000到10000之间,精确到小数点后1位)。没有两个星星会在同一个位置。

输出

一个整数,表示一条直线上最多星星的数目。

样例输入 Copy
5
0 0
1 0
1 1
0 1
0.5 0.5
样例输出 Copy
3
import java.util.HashMap;
import java.util.Scanner;

class Point {
    double x;
    double y;

    public Point(double x, double y) {
        this.x = x;
        this.y = y;
    }
}

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt(); // Number of stars

        Point[] points = new Point[n];
        for (int i = 0; i < n; i++) {
            double x = sc.nextDouble();
            double y = sc.nextDouble();
            points[i] = new Point(x, y);
        }
        int maxCount = 2; // At least 2 points are on the same line
        for (int i = 0; i < n; i++) {
            HashMap<Double, Integer> slopeCounts = new HashMap<>();
            int samePointCount = 0;
            for (int j = 0; j < n; j++) {
                if (i != j) {
                    double deltaX = points[j].x - points[i].x;
                    double deltaY = points[j].y - points[i].y;
                    double slope = deltaX == 0 ? Double.MAX_VALUE : deltaY / deltaX;
                    slopeCounts.put(slope, slopeCounts.getOrDefault(slope, 1) + 1);
                    maxCount = Math.max(maxCount, slopeCounts.get(slope));
                    if (points[j].x == points[i].x && points[j].y == points[i].y) {
                        samePointCount++;
                    }
                }
            }
            maxCount = Math.max(maxCount, samePointCount);
        }
        System.out.println(maxCount);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wa_Automata

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值