2021-01-19(stack函数)

stack函数
头文件:#include<stack>还要加上using namespace std;
empty() 堆栈为空则返回真
pop() 移除栈顶元素
push() 在栈顶增加元素
size() 返回栈中元素数目
top() 返回栈顶元素

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stack>
using namespace std;
int main()
{
   stack<char> a;
   char c;
   int i,n;
   cin>>n;
   for(i=0;i<=n;i++){
   while(c=getchar()!='\n'){
   	    if(c==' '){
   	    	while(!a.empty()){
   	    		cout<<a.top();
   	    		a.pop();
			   }
			   cout<<' ';
		   }
		else
		a.push(c);
   }
   while(!a.empty()){
   	cout<<a.top();
   	a.pop();
   }
   cout<<endl;
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值